Версия Docker не поддерживается. Что делать?

discourse
docker

#1

ERROR: версия Docker 17.06.0-ce не поддерживается! Приложение не хочет обновляться.

docer

Я пытаюсь исправить командой:

./launcher rebuild app

Не перестраивает приложение. Не пойму, что надо делать?
Ubuntu 16.04 и Discourse 1.9.0.

Читал, что если обновлять Docker, то можно потерять изображение раннее… Плиз!


(Евгений) #2

Попробуйте:

  1. При всех обновлениях, сделайте резервные копии. Не запускайте обновление под командной строкой не создав их. Можно лишиться последней версии…

  2. Сделайте: wget -qO- https://get.docker.com/ | sh
    и дождитесь окончания процесса. Возможно он будет пугать вас:

Warning: the “docker” command appears to already exist on this system.

  1. Запустите вашу приведенную команду: ./launcher rebuild app
    при условии, что вы работаете из “нужной” папки…

  2. Дождитесь окончания обновления. Почистите систему, удалив лишнее: ./launcher cleanup
    и перезапустив: ./launcher restart app

The following command will

  • Delete all docker images for old containers
  • Delete all stopped and orphan containers

Are you sure (Y/n): y

Готово. Все должно работать.