После обновления у меня ошибка 500 (Discourse)?

Был установлен Discourse. Обновил спустя полгода. Теперь при заходе на сайт ошибка 500. Что мне делать?

3 Симпатий

Вы должны дать больше информации, чтобы мы могли помочь вам.

  1. Какая версия у вас была?

  2. Вы использовали стандартную установку?

./discourse-setup

В противном случае поддержка может быть ограничена…

  1. У вас установлены плагины?
    Попробуйте удалить все неофициальные плагины.

  2. Вы пробовали безопасный режим?
    Для доступа в безопасном режиме перейдите по ссылке: your-site-name/safe-mode

  3. Что говорят логи сервера?
    Возможно вам придется зайти в контейнер.

  4. Вы использовали discourse-doctor утилиту, которая помогает людям устранять неполадки?
    Запустите ./discourse-doctor и дайте лог сюда…

P.S. 99% ошибка связана с использованием сторонних плагинов, которые имеют конфликт с новым ядром. Удалите их из конфигурационного файла и перестройте приложение:

cd /var/discourse
git pull
./launcher rebuild app

Вы можете использовать ЛС, для уточнения деталей. Пишите.

6 Симпатий