Ошибка в sshd шаблоне (sshd.template.yml), как исправить?

Возможно вы сталкивались с бесконечным циклом предупреждений.

Aborting
failed to update
Ensuring launcher is up to date
Fetching origin
Updating Launcher
Updating 8868a36..1a1ea03
error: Your local changes to the following files would be overwritten by merge:
        templates/sshd.template.yml
Please commit your changes or stash them before you merge.
Aborting
failed to update
Ensuring launcher is up to date
Fetching origin
Updating Launcher

Не могу перестроить далее.

3 симпатии

Мы этим были заняты последнее время (и сегодня). Дело в том, как пишут на оф. форуме шаблон

sshd.template.yml

был удален в январе 16!

Как мы пропустили это?

У нас он аналогично использовался. :slight_smile:

В общем решение.

  1. Восстановить шаблон.
git checkout -- templates/sshd.template.yml
  1. Убрать его из загрузки app…yml

  2. Перестроить приложение.

./launcher rebuild app

Мы ранее изменили sshd.template убирали строки:

root@  diff templates/sshd.template.yml templates/sshd.template.yml.backup
40a41,43
>         - rm /etc/update-motd.d/00-header
>         - rm /etc/update-motd.d/10-help-text
>         - rm /etc/legal

но буквально вчера они пофиксили это дело. Но в любом случае это шаблон не нужен. Мы просто восстанавливаем его для дальнейшей перестройки.

Меньше кода лучше! :wink:

5 симпатий