Какие требования нужны для установки Discourse?

хостинг
discourse
программирование

(Андрей Белов) #1

Почему Discourse официально поддерживаете только Docker? Какие минимальные требования предъявляются и нужны для установке приложения Discourse?


(Герман) #2

Почему Discourse официально поддерживаете только Docker?

Приложения для хостинга Rails сложны. Даже если у вас уже установлены Postgres, Redis и Ruby на вашем сервере, вам все равно нужно беспокоиться о запуске и мониторинге процессов Sidekiq и Rails, а также о настройке Nginx.

Благодаря Docker система полностью оптимизированная конфигурация Discourse доступна вам в простом контейнере вместе с веб-графическим интерфейсом, который упрощает обновление до новых версий Discourse простым нажатием кнопки.

Требования к оборудованию

  • Cовременный одноядерный процессор, рекомендуется двухъядерный процессор
  • 1 GB RAM минимум (с swap)
  • 64 bit Linux совместимым с Docker
  • 10 GB минимум на диске

Требования к ПО

  • Postgres 9.5+
  • Redis 2.6+
  • Ruby 2.3+ (рекомендовано 2.3.1 или выше)

Discourse проектируется на следующие 10 лет Интернета, поэтому требования высоки:

Browsers Tablets Phones
Safari 6.1+ iPad 3+ iOS 8+
Google Chrome 32+ Android 4.3+ Android 4.3+
Internet Explorer 11+
Firefox 27+

Исходники: https://github.com/discourse/discourse

P.S.

Официальные релизы Discourse, а также планы будущих релизов:

https://meta.discourse.org/c/releases :+1:

Актуальная версия на June 20, 2018 (Europe: Moscow) - v2.1.0.beta1

Еще вопросы по платформе: (на этом сайте)

https://toxu.ru/c/programming/discourse