Как обновить Discourse?

discourse

#1

Discourse (1.9) стоит локально на компьютере (Ubuntu). Как мне лучше обновить Discourse до последней версии? Docer не стоит.


(Евгений) #2

Делаем архив базы и всех файлов, всех изменений, что были.

  1. Удаляем папку Discourse (всё остальное будет написано для стандартной установки).
  2. Заливаем себе приложение заново:

git clone https://github.com/discourse/discourse.git ~/discourse

  1. Идем в папку и выполняем:
cd ~/discourse
source ~/.bashrc
bundle install
  1. Далее, выполняю команду:

bundle exec rake db:migrate db:test:prepare db:seed_fu

  1. Запускаю:
bundle exec rake autospec
bundle exec rails server

Готово. Discourse установлен, обновлен и должен работать. Если не будет, пишите.


#3

Спасибо, получилось. Но восстановление не работает.

EXCEPTION: psql failedи ругается на restorer


(Евгений) #4

А что у вас в настройках: allow restore?


(Официальный аккаунт) #5

Сообщение перенесено в новую тему: Как использовать Discourse для академического обучения?